Limbajul Pseudocod

Pseudocodul (codul fals) este considerat un cod fals deoarece nu poate fi folosit pentru a exprima instrucțiunile care se dau calculatorului pentru a rezolva problema descrisă de algoritm (nu poate fi folosit ca limbaj de programare).

  Limbajul pseudocod este un limbaj nestandardizat care folosește cuvinte cheie pentru a descrie operațiile ce trebuie executate.

  Scrierea unui program în pseudocod nu reprezintă o dificultate din punct de vedere structural, întrucât nu sunt multe reguli de scriere/formatare. Spre exemplu, citirea sau afișarea unei variabile se face prin simpla instrucțiune citește, respectiv afișează.

În pseudocod putem folosi diacriticile atunci când dăm nume unor variabile, sau scriem numele structurilor de control (ex. repetă..până când), dar folosirea lor în C++ trebuie evitată.


Exemplu

  Următorul exemplu conține un program descris în limbajul pseudocod care determină media aritmetică a trei numere naturale.

citește a,b,c (numere naturale)
S=(a+b+c)/3
scrie S

Structuri de control

Structurile de control fac parte din capitolul dedicat, structuri de control. Cu toate acestea, am atașat legături cu acele structuri specifice limbajului pseudocod.

Denumire material Descriere pe scurt
Introducere Definirea structurilor de control și clasificarea lor.
dacă - altfel Permite condiționarea executării unei instrucțiuni în funcție de valoarea de adevăr a condiției.
cât timp..execută Structură repetitivă care permite executarea instrucțiunilor cât timp este îndeplinită o condiție.
repetă..până când Structură repetitivă cu test final care execută instrucțiunile și apoi verifică condiția, pentru a stabili dacă se repetă executarea.
pentru Permite executarea repetitivă a unor instrucțiuni, de un anumit număr de ori. Este denumită și „structură repetitivă cu număr cunoscut de pași”.
în cazul Permite executarea instrucțiunilor pe cazuri, în funcție de valoarea numerică a expresiei (condiției).