repetă...până când

Schema logica instructiunea repeta..pana cand

  Instrucțiunea repetă ... până când este asemănătoare cu do while, ele având un efect asemănător. Cu toate acestea, există o mică deosebire ce poate fi înțeleasă prin traducerea celor două denumiri. Instrucțiunea do while (tradusă „execută cât timp”) va executa instrucțiuni cât timp condiția este adevărată. Instrucțiunea repetă până când execută instrucțiuni până când o condiția devine adevărată.

Sintaxă

┌─repetă
│   <instructiuni>
└■ până când <conditie>

Efect

  1. se execută secvența de instrucțiuni;
  2. se determină valoarea de adevăr a condiției;
  3. dacă valoarea este 'false' se reia pasul 1;
  4. dacă valoarea este 'true' se trece la următoarea instrucțiune din program.

Implementare

Enunț: Să se afișeze cifra maximă a unui număr citit de la tastatură.

citește n
max<-0
┌─repetă
│ ┌─dacă n%10>max atunci
│ │   max<-n%10
│ └■
│   n<-[n/10]
└■ până când n=0
scrie max
56467
7
11111
1

  Pentru rezolvarea algormului am folosit o structură repetă ... până când care va rula atâta timp cât condiția este falsă, adică n este diferit de 0. Se va trece la următoarea instrucțiune din program când condiția este adevărată, adică până când n este 0.